Treating all wrapper types the same (wasm/interfaces/plugins)


Currently, it is not clear if we should call only wasm-based wrappers “wrappers”, or if plugins & interfaces are “wrappers” as well.

If you call everything wrappers (wasm modules, plugins, interfaces), it can help simplify the architecture & create a more easy-to-understand developer experience (which is explored further here: Invoking Interfaces + Wrappers/Plugins As Implementations).


Discord Conversation
Kris: If we want to refer to plugins as wrappers, that makes sense to me from a branding point of view. We can say “wasm wrappers” and “plugin wrappers”, or something similar.
Jure: This was the exact conclusion @dOrgJelli and I came to on a call recently
Niraj: that makes sense!
Jordan: Yes it makes it easier to understand the architecture if you call everything ‘wrappers’. The underlying implementation (plugin or wasm) shouldn’t actually matter to the user of the wrapper, everything is just a wrapper.


Treat them all the same :smiley: everything is a “wrapper”.